[GUIDA] Selezionare la versione del MAME

Qui si parla di M.A.M.E.
Rispondi
Avatar utente
Guybrush
Site Admin
Messaggi: 1889
Iscritto il: gio feb 25, 2016 6:33 pm
Ha ringraziato: 12 volte
È stato ringraziato: 32 volte

[GUIDA] Selezionare la versione del MAME

Messaggio da Guybrush » gio giu 02, 2016 10:28 am

In RetroPie ci sono diverse versioni del MAME e ognuna ha bisogno del suo preciso set per funzionare.

Attualmente (Settembre 2019) abbiamo che:

Codice: Seleziona tutto

mame4all usa il set 0.37b5
lr-mame2000 (ex lr-imame4all) usa il set 0.37b5 
lr-mame2003 usa il set 0.78
lr-mame2003-plus usa il set 0.78 e parte del 0.188
advmame-0.94 usa il set 0.94
advmame-1.4 usa il set 0.106
advmame usa il set 0.106
lr-mame2010 usa il set 0.139
lr-mame2015 usa il set 0.160
lr-mame2016 usa il set 0.174
Per lr-mame2003-plus scaricate il file XML/DAT da qui (tasto dx, salva). Inoltre è presente un generico lr-mame che usa una versione molto recente (controllate qui quale) del M.A.M.E.

In generale potete dare un'occhiata qui per eventuali cambiamenti:
https://github.com/retropie/retropie-setup/wiki/MAME

Alcune cartelle predisposte per inserire le roms sono comuni alle diverse versioni dell'emulatore, quindi è necessario selezionare quale emulatore si vuole usare. Per farlo dovete editare i files di configurazione che si trovano in questi percorsi:

Codice: Seleziona tutto

/opt/retropie/configs/mame-advmame/emulators.cfg
/opt/retropie/configs/mame-libretro/emulators.cfg
/opt/retropie/configs/mame-mame4all/emulators.cfg
sostituendo l'emulatore indicato in "default=" con uno tra quelli presenti nel file, ad esempio per i mame-advmame:

Codice: Seleziona tutto

default="advmame-1.4"
In aggiunta è possibile selezionare per ogni rom con quale emulatore deve essere eseguita, vi basterà premere e tenere premuto un qualsiasi pulsante durante l'avvio di un gioco per aprire il Runcommand Launch Menu ed effettuare la selezione
"Dobbiamo costruire computer per le masse, non per le classi" J. Tramiel
_____________________________________________________________
Aiutiamo il forum con una donazione :-)

Hardware:
Raspberry Pi B (x2)
Raspberry Pi 3B
Raspberry Pi Zero W
Raspberry Pi 3A+

Avatar utente
Guybrush
Site Admin
Messaggi: 1889
Iscritto il: gio feb 25, 2016 6:33 pm
Ha ringraziato: 12 volte
È stato ringraziato: 32 volte

Re: [GUIDA] Selezionare la versione del MAME

Messaggio da Guybrush » gio giu 02, 2016 10:29 am

Riservato
"Dobbiamo costruire computer per le masse, non per le classi" J. Tramiel
_____________________________________________________________
Aiutiamo il forum con una donazione :-)

Hardware:
Raspberry Pi B (x2)
Raspberry Pi 3B
Raspberry Pi Zero W
Raspberry Pi 3A+

Avatar utente
el_dambro
Messaggi: 4
Iscritto il: gio ago 18, 2016 8:33 pm
Ha ringraziato: 0
È stato ringraziato: 0

Re: [GUIDA] Selezionare la versione del MAME

Messaggio da el_dambro » mer nov 23, 2016 10:58 am

Ho notato che nel menu sperimentale c'è anche una generica lr-mame.
A quale versione corrisponde?
Grazie!

Avatar utente
Ionic
Messaggi: 452
Iscritto il: ven giu 03, 2016 9:34 pm
Ha ringraziato: 6 volte
È stato ringraziato: 3 volte

Re: [GUIDA] Selezionare la versione del MAME

Messaggio da Ionic » sab nov 26, 2016 10:03 am

el_dambro ha scritto:Ho notato che nel menu sperimentale c'è anche una generica lr-mame.
A quale versione corrisponde?
Grazie!
Non è specificato, prova a vedere se adesso hanno aggiunto qualche file che indica il romset, leggi questo post:
http://www.retropie-italia.it/viewtopic ... &t=59#p103

akira76
Messaggi: 46
Iscritto il: sab set 09, 2017 5:30 pm
Ha ringraziato: 0
È stato ringraziato: 0

Re: [GUIDA] Selezionare la versione del MAME

Messaggio da akira76 » sab ott 07, 2017 9:43 am

Ciao a tutti, proprio in questo periodo sto "lavorando" sulla parte riguardante il MAME, scelta dell'emulatore e Romset, ho un Raspberry Pi 3B, attualmente sto utilizzando Ir-mame2003 con il suo Romset 0.78 ma ho alcune lacune visto che è da poco che mi sono lanciato in questo hobby :) ho scelto di utilizzare il Ir-mame2003 perchè mi sembrava quello più stabile e performante leggendo quà e là ma accetto volentieri consigli a riguardo...per quanto riguarda i romset la mia domanda inizialmente era: Perchè cosi tante versioni??? :o :| Questa cosa credo di averla capita, mi spiego le versioni di romset maggiori integrano le rom delle versioni precedenti...giusto??? nel senso nella 0.139 romset ci dovrebbero essere tutte le rom della 0.78 ed altre in più e cosi via per le altre versioni, è chiaro che nonostante il Raspberry Pi 3 sia un bel "aggeggio" difficilmente farà girare rom recenti dove non basta 1.2Ghz di processore e 1 giga di Ram...questa cosa mi è chiara...quindi la mia domanda nasce spontanea, qual'è il miglior emulatore per MAME appunto da poter utilizzare sul raspberry pi 3b??? ho un alimentatore da 3A, immagino che alcune rom mettano il piccolo ma efficente raspberry sotto stress...Voi cosa utilizzate??? stavo valutando di fermarmi al massimo al Ir-mame2014 con il romset 0.159...consigli??? :)


Avatar utente
nikoh
Messaggi: 28
Iscritto il: gio giu 02, 2016 7:39 pm
Ha ringraziato: 0
È stato ringraziato: 0

Re: [GUIDA] Selezionare la versione del MAME

Messaggio da nikoh » mer ott 11, 2017 6:59 pm

akira76 ha scritto:Ciao a tutti, proprio in questo periodo sto "lavorando" sulla parte riguardante il MAME, scelta dell'emulatore e Romset, ho un Raspberry Pi 3B, attualmente sto utilizzando Ir-mame2003 con il suo Romset 0.78 ma ho alcune lacune visto che è da poco che mi sono lanciato in questo hobby :) ho scelto di utilizzare il Ir-mame2003 perchè mi sembrava quello più stabile e performante leggendo quà e là ma accetto volentieri consigli a riguardo...per quanto riguarda i romset la mia domanda inizialmente era: Perchè cosi tante versioni??? :o :| Questa cosa credo di averla capita, mi spiego le versioni di romset maggiori integrano le rom delle versioni precedenti...giusto??? nel senso nella 0.139 romset ci dovrebbero essere tutte le rom della 0.78 ed altre in più e cosi via per le altre versioni, è chiaro che nonostante il Raspberry Pi 3 sia un bel "aggeggio" difficilmente farà girare rom recenti dove non basta 1.2Ghz di processore e 1 giga di Ram...questa cosa mi è chiara...quindi la mia domanda nasce spontanea, qual'è il miglior emulatore per MAME appunto da poter utilizzare sul raspberry pi 3b??? ho un alimentatore da 3A, immagino che alcune rom mettano il piccolo ma efficente raspberry sotto stress...Voi cosa utilizzate??? stavo valutando di fermarmi al massimo al Ir-mame2014 con il romset 0.159...consigli??? :)
E' proprio quello che volevo chiedere anche io, ma ancora non risponde nessuno a te quindi penso sia inutile che lo richieda anche io :-(
Comunque mi trovo nella tua stessa situazione, casomai ti msg in privato così ci scambiamo info; nel frattempo se qualcuno che ne sa più di noi ci vorrà rispondere ci farebbe contenti :-)

Avatar utente
Newton
Messaggi: 246
Iscritto il: gio ago 03, 2017 7:43 am
Ha ringraziato: 10 volte
È stato ringraziato: 4 volte

Re: [GUIDA] Selezionare la versione del MAME

Messaggio da Newton » mer ott 11, 2017 11:03 pm

akira76 ha scritto:qual'è il miglior emulatore per MAME appunto da poter utilizzare sul raspberry pi 3b??? ho un alimentatore da 3A, immagino che alcune rom mettano il piccolo ma efficente raspberry sotto stress...Voi cosa utilizzate??? stavo valutando di fermarmi al massimo al Ir-mame2014 con il romset 0.159...consigli??? :)
Chi ha superato i 30 anni sicuramente associa il MAME alle vecchie glorie anni '80-'90, anche perché è in quegli anni che i coin-op hanno dato il massimo.

Direi che con lr-mame2014 di certo si possono eseguire tutti i giochi di quei 2 decenni ma penso che lo stesso si possa fare anche con versioni precedenti ;-)

lr-mame2003 è sufficiente a mio parere :-)
Ultima modifica di Newton il mer ott 11, 2017 11:04 pm, modificato 1 volta in totale.

redice
Messaggi: 2
Iscritto il: mer nov 13, 2019 8:41 pm
Ha ringraziato: 0
È stato ringraziato: 0

Re: [GUIDA] Selezionare la versione del MAME

Messaggio da redice » mer nov 13, 2019 8:46 pm

Ciao a tutti,
mi sapete dire come mai dopo che setto come default "lr-mame2010" in "/opt/retropie/configs/mame-libretro/emulators.cfg" funziona tutto, ma quando un gioco esce da solo (senza hotkey) dopo il timeout e ritorna al menu di selezione mi ritrovo la configurazione in "/opt/retropie/configs/mame-libretro/emulators.cfg" sovrascritta e il default torna lr-mame2000?

Grazie

Avatar utente
Guybrush
Site Admin
Messaggi: 1889
Iscritto il: gio feb 25, 2016 6:33 pm
Ha ringraziato: 12 volte
È stato ringraziato: 32 volte

Re: [GUIDA] Selezionare la versione del MAME

Messaggio da Guybrush » mer nov 13, 2019 8:49 pm

Cosa significa "esce da solo"???
"Dobbiamo costruire computer per le masse, non per le classi" J. Tramiel
_____________________________________________________________
Aiutiamo il forum con una donazione :-)

Hardware:
Raspberry Pi B (x2)
Raspberry Pi 3B
Raspberry Pi Zero W
Raspberry Pi 3A+

redice
Messaggi: 2
Iscritto il: mer nov 13, 2019 8:41 pm
Ha ringraziato: 0
È stato ringraziato: 0

Re: [GUIDA] Selezionare la versione del MAME

Messaggio da redice » gio nov 14, 2019 12:08 am

Significa che avvio un gioco con lr-mame2010, non metto gettoni e quindi lo lascio girare in "demo", vado a fare altro e quando torno 10minuti dopo mi ritrovo il retropie di nuovo alla schermata di selezione (con l'lr-mame2000 tornato ad essere l'emu di default).

Rispondi