[RISOLTO] Video filter su Retropie PI ZERO

Qui trovate tutti i thread riguardanti la risoluzione di problemi di diversa natura. Scrivete qui per ricevere supporto se il vostro problema è generico o non esiste (ancora) la sezione apposita per il sistema con cui avete problemi
Rispondi
stefano.p
Messaggi: 6
Iscritto il: gio set 26, 2019 8:06 am
Ha ringraziato: 0
È stato ringraziato: 0

[RISOLTO] Video filter su Retropie PI ZERO

Messaggio da stefano.p » gio set 26, 2019 8:11 am

A qualcuno funziona il Video Filter = FALSE su Retropie PI ZERO ?
Vorrei eliminare o ridurre l'effetto di sfocatura dei pixel sui giochi.
Andando in CONFIGURATION / VIDEO FILTER = OFF, si seleziona il modo
MA non cambia niente nei giochi.

Grazie per l'aiuto

Avatar utente
Newton
Messaggi: 230
Iscritto il: gio ago 03, 2017 7:43 am
Ha ringraziato: 10 volte
È stato ringraziato: 4 volte

Re: Video filter su Retropie PI ZERO

Messaggio da Newton » gio set 26, 2019 9:38 am

Supponiamo tu voglia eliminare l'effetto solo per il Super Nintendo, apri il terminale ed esegui (qui trovi tutte le guide sui comandi Linux) questo comando

Codice: Seleziona tutto

nano /opt/retropie/configs/snes/retroarch.cfg
e prima di questa linea

Codice: Seleziona tutto

#include "/opt/retropie/configs/all/retroarch.cfg"
aggiungi questa riga

Codice: Seleziona tutto

video_smooth = false
In questo modo disattivi l'effetto di smooth, l'immagina sarà nitida ma ovviamente sembrerà più "pixellosa". Se vuoi applicare l'opzione a tutti i sistemi il file da modificare è un altro, aprilo con questo comando:

Codice: Seleziona tutto

nano /opt/retropie/configs/all/retroarch.cfg
Tutto ciò è valido per gli emulatori Libretro, ovvero quelli che hanno il nome che inizia con lr-
Ti consiglio successivamente di seguire questa guida per aggiungere l'effetto scanlines

stefano.p
Messaggi: 6
Iscritto il: gio set 26, 2019 8:06 am
Ha ringraziato: 0
È stato ringraziato: 0

Re: Video filter su Retropie PI ZERO

Messaggio da stefano.p » gio set 26, 2019 1:58 pm

Ok.
L'emulatore che ho selezionato è il mame4all, dovrebbe essere della famiglia liberetro?

Quindi, eliminare l'effetto di smooth dei pixel NON è possibile tramite emulation station / configuration. Giusto?

Grazie per l'indicazione. Seguirò la procedura dal terminale di Linux.

Avatar utente
Guybrush
Site Admin
Messaggi: 1694
Iscritto il: gio feb 25, 2016 6:33 pm
Ha ringraziato: 12 volte
È stato ringraziato: 15 volte

Re: Video filter su Retropie PI ZERO

Messaggio da Guybrush » gio set 26, 2019 2:12 pm

stefano.p ha scritto:
gio set 26, 2019 1:58 pm
L'emulatore che ho selezionato è il mame4all, dovrebbe essere della famiglia liberetro?
No, l'equivalente Libretro si chiama lr-mame2000 (ex lr-imame4all, vedi qui) che appunto inzia con lr- come ti hanno già scritto
"Dobbiamo costruire computer per le masse, non per le classi" J. Tramiel
_____________________________________________________________
Aiutiamo il forum con una donazione :-)

Hardware:
Raspberry Pi B (x2)
Raspberry Pi 3B
Raspberry Pi Zero W

stefano.p
Messaggi: 6
Iscritto il: gio set 26, 2019 8:06 am
Ha ringraziato: 0
È stato ringraziato: 0

Re: Video filter su Retropie PI ZERO

Messaggio da stefano.p » gio set 26, 2019 10:46 pm

Ok fatto. I pixel sono a posto.

Ma due problemi (Non voglio annoiare ditemi solo che al limite reinstallo tutto).

1. Il gioco ha uno schermo a forma di botte. Molto accentuata. Bruttissima.

2. Se voglio uscire dal gioco e premo esc (come in mame4all) invece di tornare alla emu station si blocca tutto e devo spegnere e riaccendere.

Ho controllato nel file di configurazione e VIDEO SHADER ENABLE = FALSE ma invece # video shader = ""

Se torno a mame4all tutto ok ma ovviamente i pixel sono sfocati.

Grazie


Avatar utente
Guybrush
Site Admin
Messaggi: 1694
Iscritto il: gio feb 25, 2016 6:33 pm
Ha ringraziato: 12 volte
È stato ringraziato: 15 volte

Re: Video filter su Retropie PI ZERO

Messaggio da Guybrush » ven set 27, 2019 7:00 am

Dalle domande che fai è chiaro che non hai installato RetroPie da solo scaricando l'immagine ufficiale. Altrimenti non è possibile che tu abbia uno shader attivo di default. Se hai preso un'immagine da internet piena zeppa di roms sappi che è illegale.

Ti do qualche indicazione, se vuoi supporto devi usare un'immagine ufficiale sennò diventa difficile aiutarti.

Per disattivare lo shader responsabile dell'effetto di distorsione stile CRT leggi qui. Per uscire dagli emulatori Libretro invece devi premere Select+Start, ma non quelli dell'eventuale sistema in uso (tipo il Select e lo Start del Super Nintendo) ma quelli impostati in EmulationStation quando ti ha chiesto di configurare i controlli.

Infine se vuoi i controlli configurati ad hoc devi seguire questa guida, altrimenti se ti accontenti di avere il pulsante A del RetroPad che corrisponde al pulsante C del Mega Drive, al pulsante B del Dreamcast... va bene così... Se non sai cosa sia il RetroPad... leggi appunto la guida!

Un'ultima cosa:
stefano.p ha scritto:
gio set 26, 2019 10:46 pm
Ho controllato nel file di configurazione e VIDEO SHADER ENABLE = FALSE ma invece # video shader = ""
Rileggi mai cosa scrivi? Abbi pazienza ma non è chiaro
"Dobbiamo costruire computer per le masse, non per le classi" J. Tramiel
_____________________________________________________________
Aiutiamo il forum con una donazione :-)

Hardware:
Raspberry Pi B (x2)
Raspberry Pi 3B
Raspberry Pi Zero W

stefano.p
Messaggi: 6
Iscritto il: gio set 26, 2019 8:06 am
Ha ringraziato: 0
È stato ringraziato: 0

Re: Video filter su Retropie PI ZERO

Messaggio da stefano.p » ven set 27, 2019 7:25 am

No no.
Immagine comprata da nessuna parte. Non saprei neanche dove o cosa. Scaricata dal sito retropie versione 4.5 PI zero. Flashata su una sd da 16 GB con un programma windows. Poi avviata e funzionante. Con mame4all. Un emulatore soltanto mi interesserebbe qualche giochetto 2D vecchio stile e basta che funzioni però. Comunque quello che ho scritto è quello che succede. Ho sicuramente lavorato sulla configurazione attraverso emulation station nei tentativi vari. Forse è rimasto qualche refuso. Reinstallero' tutto da zero.

stefano.p
Messaggi: 6
Iscritto il: gio set 26, 2019 8:06 am
Ha ringraziato: 0
È stato ringraziato: 0

Re: Video filter su Retropie PI ZERO

Messaggio da stefano.p » sab set 28, 2019 9:22 am

Grazie per le info.

ho ricaricato tutto (retropie 4.5.1 su SD etc. + 1 ROM tramite la chiavetta USB su ARCADE)
I pixel funzionano bene adesso, con l'emulatore lr-mame2000, la ROM è del tipo 0.37b5.

Rispondi